在加载实现它的函数之前,检查主题对给定功能的支持。

原型

require_if_theme_supports( string $feature, string $include )

参数

$feature (string) (Required) 正在检查的功能。

$include (string) (Required) 文件的路径。

返回值

(bool)  如果当前主题支持所提供的功能,则为True,否则为false。

源文件

路径:wp-includes/theme.php

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
<?php
...
function require_if_theme_supports( $feature, $include ) {
	if ( current_theme_supports( $feature ) ) {
		require ( $include );
		return true;
	}
	return false;
}

...
?>

其他

英文文档:https://developer.wordpress.org/reference/functions/require_if_theme_supports/